Universal Robots+

UR-image SW5.8.2 - Bug in "Settings" -> "URCap" / "Back-up" / "Register Robot"

Summary

Ather fresh install of Polyscope-image SW 5.8.2 the funcionalities under “Settings” do not work properly and are replicating themselfes.

Introduction to the issue

Versions

  • Affected Robot Software Version(s): SW5.8.2
  • Affected Robot Hardware Version(s): UR10e
  • Robot Serial Number: 20195000126
  • UR+ product(s) installed: none
  • URCaps Software version(s): own UR-Cap with SDK 1.3 (i think, because a colleague did it.)

Impact

No loading of new URCaps possible.

Issue details

I have installed a fresh image for Polyscope 5.8.2 on our UR10e, using the designated SD-Card.
When I tried to add a URCap, browsed the *.urcap File and try to load it - it failed to load to the “UR-Cap”-Tab within the Settings-Window. After trying various UrCaps and rebooting, nothing changed. When I tried the other tabs, something even more misterious happened. I got more tabs displayed on the left side. Again, those were the three optiones mentioned above, but copies of them.

Steps to Reproduce

  1. Install fresh Polyscope-image SW5.8.2
  2. Try to load an URCap-file. (*.urcap)
  3. Check if file is loaded correctly and if you get more tabs on the left-hand side ot “settings”.

Expected Behavior

Tab “URCap” and others in “Settings” not working properly

Actual Behavior

No loading of *.urcap file.

Workaround Suggestion

Installing image of SW5.8.0 or SW5.7.0 and using the “update”-funcionallity instead.