Universal Robots Forum

Restart message not shown after installing an URCap

Hello,

when you install an URCap, PolyScope usually returns to the URCap setup window after pressing
the + button and selecting a .urcap file. The URcap is shown in the list with the installed
URCaps and some refresh symbol. Also a prompt to restart the robot is shown.

Randomly PolyScope just returns to the URCap setup window, but does not show the installed
URCap and does not show the restart message. But when the robot is restarted manually,
the URcap is correctly installed (visible in the URCap setup window in the list of installed
URCaps and the URCap is normally usable).

No error messages are shown (also in Ctrl+Alt+F9 terminal). Just the PolyScope GUI is
sometimes displayed differentely (it seems randomly).

The “problem” only occurs on a real robot (UR 5e), not in the offline simulator.
The URCap worked in the past.

What I’ve tried:

  • different USB drives
  • URCap with resource folder of different size (10MB-80MB. I thought there might
    be some reading timeout if the URCap is quite big)

Has someone experienced the same behaviour? Or is this problem related to our URCap?
I’m just curious as everything seems to work except the sometimes differently displayed URCap setup window in PolyScope.

Thank you very much!