“Waiting for Valid OnRobot VG ID Time out”


New to the forum so hello!!

A member of my team is having an issue with using the onrobot vgc10, he has followed the installation proccess to the letter, however when trying to run a program the error “Waiting for Valid OnRobot VG ID Time out” is displayed. we are able to toggle the gripper manually.

Kind regards


Hey @robin.dearing . I have the same problem. Were you able to solve it?

Hi @alexnic31 , we managed to work around the issue by using a pre-made installation file found on the USB supplied with the robot, the installation file however was for the onrobot soft gripper, but this worked nonetheless. however, we still could not see the difference in installation files.

I hope this is useful.

Kind regards


Thank you for your reply Robin. I tried it. In my USB there was the installation file for Gecko, and I tried it but unfortunutaly it didn’t work. No matter what I try, I get “OnRobot VG ID Timed out”

@robin.dearing I would really appreciate it if you could send me the installation file!

@peter.pinczes do you have any recommendations here?


Please check the RTDE register usage and offset.
The Ethernet/IP and other URCaps may interfere with the OnRobot URCap’s RTDE register usage.
You may find the RTDE register offset settings on the detailed “Device info” page at the Installation’s OnRobot Setup.
If the issue still occurs, please contact our Technical Support.

Best Regards,



The values are 0,0,0 in those registers do we have to change those values.??
Best regards

I also have the same question. @peter.pinczes do you have any idea on that? It would help a lot, thx!