Universal Robots Forum

URCap error remote TCP & Toolpath

for some programs we use the URCap: Remote TCP & Toolpath

ran today and yesterday into a freezing screen of the controller and couldn’t press anything on the tablet.
I could still move the cursor around the screen and the in-/outputs and the program could still be executed/was still welding.
I could even press our safe guard (which runs in a thread and will eventually use halt command to terminate the program nicely) and then use the free drive button.

thanks in advance for any solutions/suggestions

(latest version is 5.9.3)

Hello and thank you for your inquiry-

Can you firstly please confirm the following:

  • When you go to Hamburger Menu > Settings > System > URCaps the Remote TCP & Toolpath has a green check mark?

  • If the above is OK-have to tried deactivating the URCap, and then re-installing it?

  • Are you using any other functions and nodes in polyscope with the Remote TCP Move command? some of the functions/nodes in polyscope are not compatible with TCP Move command. Shown here: Universal Robots - Remote TCP & Toolpath URCap FAQ

Once the above have been checked, we can move onto the next steps of assistance.

1 Like
  • in the hamburger menu the URcaps has got a green checkmark
    -the URcap has been re-installed, problem was not solved
  • we are not using the ‘‘remote TCP move’’ command, Toolpath move command is used.

We think the problem is related to the NC and to the amount of NC’s in the program. there is a connection between the amount of NC’s and the duration of the freeze. the freezes are happening with multiple different NC’s

The program we are using is to weld a contour on a piece of stainless steel to round the edges. For every part there is a seperate NC and there are usually about 10-20 NC’s in a single program. Every NC is the same exept for the origin of the NC.

we have not updated Polyscope to version 5.10.1 as there is a problem installing it, so we do not know if it fixes the problem.

1 Like

hi @tywa and @mpa

I saw this today Out of memory Error. Could this has something to do with this? Didn’t saw anny erros in the past few weeks, but we still have a freezing screen/robot.

Corné