Teach pendant freezes UR10e

Hi,
We have installed in our factory 5 UR10e palletizing application, all of them using more or less the same program structure.
With only one we have from the begining problems. The teach pendant freezes and the cobot it’s not running the program. The only way to make him move again it’s by power off and on. We’ve tried using magic files to check the log but we do not understand what can cause the problem. We need some help.
Thanks in advance.

I have been facing same problem. When teach pendant freezes. Every time I have to restart the robot forcefully. is there any way to solve this problem. my robot is UR10e

I have figured out why teach pendant freezes. At the moment are you using any URCAPS? whatever URcaps you are using please remove it. there will be a newer version out. you have to install that version. you teach pendant will not freeze again it happens due to URcap.

In general, most of the time that polyscope appears to freeze up it’s probably due to a misbehaving urcap. If you have ANY urcaps that you are not using then uninstall them and reboot of course. If you have a urcap you ARE needing to use then make sure you have the latest version that works with that version of polyscope.

Hello again,

I have just one inactive UrCap - Remote TCP & ToolPaths from UR. I have the log from the cobot if someone 

from the support can understand what is the problem. Bellow the link.

Thank you.

One more thing if you are using any USB-hub onto the teach pendant please remove that USB or USB-hub. Yesterday my robot freezes again and than I figured out that removing USB-hub unfreeze the teach pendant no need to shut down the robot.

There is nothing connected to the robot. We have just 2 push buttons for starting and stopping the cycles and one red light for software alarm generated by some photocells mounted on the gripper and pick-up station. Also 2 outputs but the load is less
than 2 Amps, which is the maximum of the robot 24Vdc power supply. The big question is why the other 4 robots with the same software structure (just the box size different some of them longer programs) are working without freezing. First i thought to be a problem of using 5 threads running in parallel with main program, but this one has even less threads than the others.
Thank you for any guides you may have in solving this.

Are all your robots on the same version of Polyscope?

Only the one with problems is 5.11 the rest are 5.7.

Sounds like that could be your issue then. Not sure when you got the one with 5.11. If it was early enough to be rolled back to 5.7, I’d maybe try that. If not, you could try updating to 5.12 and see if that fixes it.

OK, that urcap is not going to cause a problem. The 5 threads you mention is not an issue either. You can have many more threads than that. It might have something to do with the 5.11 version so I would follow Eric F’s advice.

Ok i’ll try and let you know. Thank you all.