Universal Robots Forum

Ur10 doesn‘t boot after Update to SW 3.10.0

After successful updating of the robot from 3.7.2 to 3.8.0 and then 3.9.0 I thought why not installing the latest version 3.10.0. Now stuck with a black screen (no cursor) after 2 times UR splash screen.

Please guide me how to boot from usb or similar to get the robot working again.

Sounds like there was an issue with the update. You can try downloading a new robot image onto your flashcard to boot the robot from here.

This document may help in loading the new image. If you have any further issues I would reach out to your local distributor for support.

How to_DuplicateUSBflashDrive.pdf (301.1 KB)

One possibility can be that there was not enough space to complete update.
You can check it by switching to linux console, and typing df -h. Check “Avail” column for rootfs.

Didn‘t manage to rescue any data from the HDD but was able to install a new image. Worked like a charm!
Keeping my hands off 3.10. though.

Disk space was definitely not a problem.

One last question remains. Can i install the image on any usb stick or does it have to be the provided one that came with the robot?

Thanks a lot in advance.

Hello Weinbacher

You can install image software on any usb stick.

Usually when you connect the Cobot usb to laptop, it will always ask for “Format Disk”, if you format the disk then you will loose all program data and original calibration files of the robot from the disk and then again you have to load the image software on it in order to get it right.

Thanks

Hello!

I’m not sure if it’s the same problem, but after installing 3.10 our robot got stuck in booting sequence for several minutes, but it did manage to start after a while. We have been trying to see if it’s our URCaps that caused the issue, but even without any URCap or anything, it was still slow.
Today I decided to try to just downgrade to 3.9 again, and then it worked like a charm first time. Installing the URCaps, it’s still as quick as it should.

Also the same with eSeries 5.4.
I downgraded to 5.3 now.
Startup time on 5.4 was over 5 minutes, meanwhile on the 5.3 it’s less than a minute.

I might try with a clean image, but I’ll have to wait with that 'til next week.

Could you send contents of /var/log from robot?

They didn’t change the update. The checksum is still the same. On my UR10 there were many URcaps installed, like Robotiq FT300, RG2, from Onrobot, Weiss gripkit and several smaller productivity URcaps.

If you install a new image please do not forget to make 1. a backup, 2. make sure to plug in the usb stick on a linux computer with ext4 filesystem to rescue the robot calibration files.

Hello
I have the same problem. With version 5.4 the robot takes 8 minutes to startup…
I downgraded to version 5.3 and it takes less than 2 minutes.

Same Problem with UR10e … update 5.4.0 6min -> Update 5.4.2. 8min …… 5.3 was not installed at delivery

We have seen similar issue when robot network is configured to static IP address, and network is either unavailable or unplugged.
Try to disable network or change to DHCP.