Stuck at EFI Shell on booting UR10

Hi, something has happened to my UR10 and now when I boot the robot I see the Universal Robotics logo then it takes me to a black screen with “EFI Shell version 2.31 [5.9]”

Following the instructions to install a new image I was able to access and back up my files (I created a full backup image of the USB as well) then wrote a fresh 3.13 image (same version that it had been running previously) to the USB drive using GNOME Disks on a Ubuntu Laptop.

Unfortunately this has not changed anything and I still get stuck at the EFI Shell when I boot the robot.

How can I get my robot back up and running again?

I just imaged another USB stick and tested it to rule out the USB stick itself as the issue. Unfortunately I get the same result with the new USB stick.

Well, It appears I have resolved this issue. I stuck the original USB stick back into the control box and for whatever reason it just worked. Maybe the contacts in the USB port just needed some exercise.

If someone else encounters this issue you might try just inserting and removing the USB stick a few times to clean up the contacts a bit.

Good luck!