Universal Robots Forum

Uninstall URCaps over FTP

Hi all.

I recently installed an old URCap on our CB3 UR5, and it has unfortunately bricked the robot preventing it from completeing the boot sequence. The robot boots as normal until it reaches 100% in the initial loading screen. The pendant is still responsive, as the mouse can still be moved. Looking at the robots console by pressing CTRL+ALT+F9, I can see that the robot is frozen at 100% as the URCap is trying stuck in an endless thread, trying to open a network connection that it will ever be able to connect to.

As a result, I have tried to manually FTP into the robot with FileZilla to remove the broken URCaps, however, I am clearly not removing enough reference data, as when I delete the files and reboot the robot, they are loaded back in again.

I have been removing the offending URCaps from the path “root/.urcaps” but they re-appear whenever the robot is rebooted, so I am assuming they are stored elsewhere. If anyone could point me in hte right direction to be able to either fully remove the URCaps over FTP, or remove enough to let me get through to polyscope and remove the URCaps the usual way, it would be much appreciated.

Thanks,
Sam

Hi @sam.hilton, no idea if this will work, but you can deploy remotely using mvn install as documented in the below article… perhaps you can remove using mvn clean following the same methodology? I haven’t done a lot with our java sdk, perhaps someone with more experience can elaborate on the clean command… I’d probably just reformat the disk instead.

https://plus.universal-robots.com/urcap-basics/deployment-options/

Andrew

Thanks for the reply, though the solution was actually simpler than expected. It seems I was restarting the robot too soon after having deleted the files, and it the files werent deleted properly when the robot was restarted, and the URCaps were reinstalled. If i waited a few minutes after deleting the files and restarting, the URCaps would not reinstall and I the robot booted as normal.

If this hadn’t worked then I would have been forced to reflash the robot.