Universal Robots Forum

Palletizing not following updated waypoints

I have programmed an UR5e with one palletize and one depalletize.

After a collision I had to adjust the corners, approach, exit and anchor point. But when I run the program it continues to use all the old positions. Going through each waypoint and letting the robot move to it makes it move to it perfectly and grip the parts exactly as intended, but going back and running the program again, makes it use the original values and miss the part.

I have done it exactly like this a lot on our old UR10 CB2 and on our CB3 too without problems. The only way I have been able to do it on the e series is to completely delete the palletize routine and create a new. But the new one has to be perfect the first time, if I need to change the new one, it also won’t update the positions.

Is this a bug, or do I need to do it in another way?

1 Like

I have also suffered from a similar problem with a depalletising routine. In manual mode I can drive the robot to the required waypoints and it goes exactly there but in auto mode there is an offset of up to 5mm. I have also tried starting a new pallet and this worked until I edited one position.

The polyscope software has been updated to the latest version and this has not fixed the issue. One suggestion I have been given is not to use blend on any of the palletising waypoints and make sure they are all linear movements. I haven’t had time to try this yet though.

1 Like