Universal Robots Forum

Need Robot software above 5.4

Hi there.
New in this forum.
Trying to get Robotiq Copilot to work on a UR10e.
The robot is running 5.9.3.1031212
Robotiq Copilot needs at least 5.9.4 to run properly.
Support download site only offers up to 5.9.1
A simple google search gives me this UR site offering all incremental updates:
https://www.universal-robots.com/articles/ur/documentation/all-legacy-download-center/
I only found out after downloading the 5.9.4 and 5.9.5 and trying to update that UR removed all incremental downloads after 5.9.1 due to risk on currupting all axis data.
I need help to run the two updates on the robot because I need it for the Copilot URCap software to work. But I get an error when trying to update. What do I do?
Regards
Rasmus