Controlling a UR5 CB3 with ROS2 and Ubunut 22: Connection refused

I have updated the UR5 to the latest firmware version 3.15.8 and physically connected it via LAN to a Computer with newly installed Ubuntu 22.04 on it.
I have then followed this tutorial (GitHub - UniversalRobots/Universal_Robots_ROS2_Driver: Universal Robots ROS2 driver supporting CB3 and e-Series) and the referenced tutorials. I have followed them to the best of my knowledge and have also always gotten the expected responses. Just in the last step “4. Run the external_control program by pressing play on the teach pendant.” I run into a problem.
When I press play, i get the error “the connection to the remote PC at could not be established. Reason: Connection refused”.
I have restarted the PC and the robot, I have pinged the IP of the Robot via my Computer successfully and deactivated the firewall for Port 50002, which is the port of the robot according to my settings (sudo ufw allow 50002).
I tried Real robot is not moving with moveit - #4 by mauch this advice, which asked me to hard-code the IP address into the ur_robot_driver, but that did not change anything.

Do you guys have any idea what I could do? I am not super proficient with coding and normally focus more on the hardware, so please be kind.

Edit: I just figured out that I get the same error message, it does not matter if I ran “ros2 launch ur_robot_driver ur_type:=ur5 robot_ip:=” before or not

Edit 2: We now tried it with three different PC’s with Ubuntu 22 running on each and the driver installed. All had the same problem.