External Control Connection refused

I am working on ROS2 Foxy, my network setup is UR3e ( > router > PC (Ubuntu with IP and another network for docker with IP > ROS2 (through docker with IP

  • I set up host IP on the robot, and robot’s IP

  • I installed the external control urcap

  • I tried with both enable/disable remote control, and with both local/remote control on teach pendant

  • Firewall is disabled (sudo ufw status: inactive)

  • I run

ros2 launch ur_bringup ur_control.launch.py ur_type:=ur5e robot_ip:= launch_rviz:=true reverse_ip:=

  • ping shows successful connection

  • Also when I connect to the robot through ssh, and I ping shows successful connection.

  • I also tried with setting as host IP the docker’s IP: and the robot’s IP: but this doesnt even ping.

For all these, the error is the same: Connection refused.
Any idea what’s wrong?
Attached is my installation and program configuration.

Thank you for your time,

URconfig.zip (3.7 KB)

Did you open the port for the robot? We had an issue of connecting with global IP, We had 2 routers in the system and it wasn’t possible to connect the robot. We opened gates with both of the routers and it works.

1 Like

I found the solution. I had to add

at the docker command. But thank you anyway

I cant see the solution that you found. Could you please show that again?