Universal Robots Forum

URSIM visualisation is flickering

Hi everyone!

I just installed URSIM on my windows machine (WIN 10). I followed the official UR Documentation for installing the VM VirtualBox (https://academy.universal-robots.com/media/jiehhszc/ursim_vmoracle_installation_guidev03_en.pdf).

Everything is working fine except that my screen with the robot visualisation is flickering. You can see it in the following .mp4-file:
Video

I´ve tried to fix it by changing the graphic controller settings in the virtual box settings:

The graphic driver for my NVIDIA Quadro is the latest version available.

But the error remains with all the options. Has anyone an idea how to fix this problem or where to search the error?

Thanks!

Every virtual box I’ve ever used has had a flickering robot graphic, I have no idea what causes it, and across the 4-5 devices ive seen URSims installed on, I have never heard of a fix. I’m afraid it’s just something to live with!

So I am kind of a fool searching the problem within my machine :D?

Not a fool, I tried to fix it first timer i ran a URSim, but i never had any luck! If on the off chance you do find something, I’d love to know what you did to fix it!!

If i can fix it, I will let you know!

Hi,

Try virtualbox 6.0 with the sub versions, not 6.1. For example, I am using 6.0.24.

https://www.virtualbox.org/wiki/Download_Old_Builds_6_0

1 Like

I am not experiencing this issue with VMWare 15. :slight_smile: So you could give this a try.

1 Like

Installed URSIM on VMware and it works without any flickering issues! Thanks a lot!

2 Likes

In my experience, VMware has less problems than virtualbox.

I don’t know if this fix will be the same for you, but using VirtualBox 6.1.18 with the Guest Additions CD Installed and enabling 3D Acceleration fixed the Flickering Issue for me.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.