Universal Robots Forum

URSim 5.10, Virtual Box, Cannot Resize Virtual Screen

Hello,

I downloaded the latest version of URSim and the latest version of Virtual Box, per the instructions on the UR website.

Here’s the problem. I can’t see half the URSim application on the virtual screen, and Virtual Box will not allow me to resize the screen resolution. It is set at 800x600, which is much too small, as you can see in the attached picture. I can scale the screen (100%, 150%, 200%, etc) but this only makes everything bigger proportionally, not fixing the problem.

The host computer is a Dell Precision M6700 running Windows 7, 64-bit.
The virtual machine is Ubuntu, 64-bit.
The graphics controller is VMSVGA. If I select any other option, it automatically turns back to VMSVGA.
VirtualBox is version 6.1.22 r144080
URSim is version 5.10.2.106319

I think I may have answered my own question.

Looks like this is a problem with running Lubuntu on a virtual machine. This tutorial solves the problem:

Basically, I changed the file:
~/.config/lxsession/Lubuntu/autostart

by adding the line:
xrandr -s 1440x900 -r 60

where 1440x900 seems to be the best resolution for my display. Saving this file and rebooting the virtual machine solved the problem.

1 Like

Thanks for this, I have the same problem.

Sorry if this seems like a stoopid question, but when I open the Autostart file it is empty. Is that normal (new install of VM)?

It was the same for me. I think it’s supposed to be empty to start.

1 Like

That worked. Thank you!

I also found this helpful:

When I’ve experienced this, its been becuase the auto-resize guest display option hasnt been enabled. You can find this in the “view” options in the top bar of the virtual box, after selecting auto resize, then try full screening the virtual box again and the guest window should automatically resize.

This only happens to me when I select Insert guest additions CD image and run the VBoxLinuxAdditions.run file, to allow shared folders to work (Doesn’t out of the box!)
Somehow this resizes the screen resolution and prevents the above fix from fixing the issue.

So I can either have a fresh install where file sharing doesn’t work or file sharing works but the screen resolution is to low and unusable.

I was actually able to get both the screen resolution and file sharing to work by following the above-referenced pdf to a tee.

I think one of the key parts is under Settings > Display > Screen, Graphics Controller should be set to VBoxVGA. This is not the default, but it works. Also note, if I try to Enable 3D Acceleration, I get a lot of crashes.