Universal Robots Forum

URSim crashes when 3D-view - Activate 3D acceleration in Virtual Box


I recently downloaded the new URSim 3.5 (URCaps Starter Package). Everything works as expected (Polyscope starts, I can setup and create or load programs, …). But when I click on the “Move” tab in polyscope it crashes after 2 seconds. I looks to me as if the 3D model of the robot can’t get loaded because the robot doesn’t show up. Same happens when I click on a Feature Point, …

Is it just me or is it a bug in the new version of URSim? Maybe someone has the same new version and could say me if he’s having the same error.

I use VirtualBox in Windows 10, if it’s necessary to know.

Thank you in advance, every answer is highly appreciated.


I think it will be helpful if you post error message. We had similar problem running it inside Docker, where we had missing or broken (due to NVIDIA configuration) of OpenGL 3D supprt (GLX extension of the X Windows driver). It could be that your Virtual Box has no 3D support enabled or that you miss GLX extension/support added in your virtual machine (but it is a wild guess). There might be multiple reasons why it can be wrong - but you can start from googling https://www.google.com/search?q=missing+glx+extension+virtualbox&oq=missing+glx+extension+virtualbox&aqs=chrome..69i57j0.8861j0j7&sourceid=chrome&ie=UTF-8

Hey jarek,

thanks for your answer! There was no error message. URSim just crashed and closed after approx. 2 seconds.

I fixed it now by activating 3D acceleration in VirtualBox. On VMware Player I haven’t had that problem before.

Thank you again.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.