Universal Robots+

Ursim problem installing urcap

URSIM CB3 3.12: …

Hello,

I downloaded the non linux virtual machine CB3 3.12 for windows (run with virtualbox).
The polyscope interface works correctly but I can not install an urcap (by the way it is for ros driver). The urcap is visible in the robot interface but nothing happen.

In the log prompt there is a message saying :
13:23:46.988 WARN - URCap does not exist: /home/ur/ursim-current/programs/externalcontrol-1.0.1.urcap

What i do not understand is that the file exists !

Here after a screenshot of my problem:

Thanks for your help.

Florent

Urcap file is zip file.
When the extension is changed to “zip”, does it have problem to uncompress the zip file?

Or, is there symbolic link “programs” under ursim-current?

I changed the extension “.urcap” in “.zip”.
And I didn’t manage to decompress it… I tried to download it again and again…and always the same problem.

The urcap is stored on github. I use the browser command “save link as …” and it was the problem.

This does not work:
2020-03-31_175408

So I clicked on the file and use the “Download” button

And it worked !
Thanks for the advice.