URSim on M1 Macbook

Is there any way to run the URSim on the new M1 Macbooks with ARM chips? Can’t run VirtualBox as it is an Intel virtualisation hypervisor and therefore not compatible with the ARM architecture. A the native install of URSim is only for Linux so I presume that won’t work.

Is this currently supported in some other way? If not, I’ll move this to “Product Wishlist” category as something to request.

4 Likes

Hey, is there any progress with that?
I have searched the web, tried docker images & vms, but all fail due to the fact that the URControl binary is incompatible with arm64.
Please Help! :frowning:

Dear UR, can we have some official response or fix from your official channels, after 6 months?

Thank you

2 Likes

Same problem here: i tried everything (vms, docker, religion) with no success. A supported version for arm64 is needed.

Success with:

brew install --cask docker
# start docker once via application menu
docker pull universalrobots/ursim_e-series
docker run --rm -it -p 5900:5900 -p 6080:6080 --platform linux/amd64 universalrobots/ursim_e-series
brew install --cask tigervnc-viewer
# start tiger vnc viewer and connect to: localhost:5900

not sure if tiger vnc is necessary. I am not very much into macos

Does the URControl run ok?
When you open the URSim, is there a No Controller in the bottom left?

The container runs fine and I can connect to it via VNC-Viewer on localhost:5900.
However, I do get the “No Controller” Error and can not do anything with the simulator. Did you run into this? If so how did you fix it?
It does appear that there is a general incompatibility of the URControl binary with arm64 systems even with virtualization. There is always some sort of error no matter what I try.

1 Like

I am on an M3 Macbook Pro. I can run URsim, but the controller stays off and can’t be turned on. Exactly like in this post:

When digging through the logs, I discovered this error:

Mutex, Unknown - Could not set the attributes. Error code = 95
Unknown Mutex::Mutex() calling exit(-1)

It seems to be related to this issue: URControl: Unknown Mutex::Mutex() calling exit (-1)

I am having this same issue. Has anyone found a way to run URSim on ARM64 macs?