Universal Robots Forum

Issue with simulator for on VirtualBox

I just loaded the simulator for and am having an issue. I am running the simulator on MacOS 10.12, inside VirtualBox 5.1.6 r110634. When I open any of the simulators from the desktop I am not able to start the controller. I see the following screen and when I press Start nothing happens. Anyone else seeing any issues like this? I have never had to actually start the controller on any of the other versions and have never had an issue.

Matt, I do not see the same issue in URSim using VMWare 12.0.0 from a Windows 7 environment.

Maybe the issue is related to the VirtualBox distribution?
Do you use the generic URSim VM machine from the Support Site?

Yes, I just downloaded it last night and opened in virtual box this morning.

I had to rebuild my computer yesterday so I will try downloading one of the older versions that I know worked before and see if I have the same issue.

Matthew Bush
M: ‭(615) 479-6151‬

@jbm I downloaded the 3.3.1 simulator and it worked as expected. I have since deleted the 3.3.2 version from the computer and VirtualBox and then redownloaded the file. Now that I have done that it seems to be working as expected. Not sure what happened with the original download or why the program would not let me start the controller.


Hi Matt

Odd issue, but great to hear it’s working!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.