Universal Robots Forum

[SOLVED] URsim wont start in virtual machine

Hi

I Im working on a URcap, and I’m reinstalling new versions regularly into the URsim (UR5) to test new functionality.
After adding som new functions, polyscope wont start after i install the .urcap file - it reaching 100% on the loading screen and then nothing.
I tried commenting out the new funcitons, so the cap looks like one that have worked in the past, but nothing.
I also tried reinstalling the entire machine on virtualBox - the same problem accours.
Anyone had experience with this? Any ideas?

Regards Kasper

Try starting ursim from command line:
cd to ursim that fails to start, and start script ./start-ursim.sh UR5
Then you will be able to see exactly what polyscope fails to load.

I tried.
I seemed like an error in a HTML file (text-size) - i removed the .urcap file from the programs folder.
I still get some sort of injection-error.
Any ideas?

Your actual error is here
image

It seems you still have an URcap that uses the “text-size” property which is not supported in polyscope at the moment.

Thanks
I got it now - reinstalled the machine (again), and removed the unsupported HTML