Universal Robots Forum

Power button on Teach Pendant doesn't work with URCap



After turning on the robot, pressing the power off or restart button from the teach pendant does not work.
Now, Press and hold the power button to force shut down.

Thank you in advance

Can you try the below?

  1. Unintall all urcaps if some urcaps are installed.
  2. Update the newest version -> e-series is SW 5.7.0.

If the problem cannot be solved, it may be better to check hardware failure via distributor.

How to uninstall the urcaps?

  • remove the .urcaps/**.jar?

I want to use the same version for a reason.

You can remove on the screen of urcaps .

I tried it.
After restarting, The urcap was enabled again.

Is there cache left?

It is maybe problem that the urcap is remained after uninstalled.
I cannot analyze the reason without understanding what urcap you use.

Did you got in touch with distributor?

If you repair the system, you can use image software.
I recommend to take a backup of UR in any case.



Thank you.

I will try it.

1 Like

This problem was due to the URCap software I developed.

Remove button is the same as deleting /root/.urcap/xxx.jar.
When an interrupt occurs, My URCap will be blocked.

The problem has been resolved.
Thanks for the advice.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.