Universal Robots+

Set Waypoint like paletization tool does

Hello,

In one of my Urcaps, I would like to cast the “Set Waypoint” function that UR use to open the move window and press “ok” to set a waypoint. This way i could set a waypoint and use it later to generate some moves by the URcaps. Just like the Palletizing tool of UR does.

Is there a way to cast the same process as UR to set a waypoint? Is there any URcaps example that does it?

My other solution would be to make the user move the robot in position and then create a “Teach Waypoint button” so i can record the actual postion of the robot in a variable. But this is less intuitive than in the Palletization exemple with the illustation of the robot, the “move here” option and the pop up of the move tab on button click…

Thank you,

Olivier

Hi @ocoulombe

This is defeinitely possible, as a colleague of mine uses it in a URCap he has written. Im not too clued up on it personally, but there is an example that you can follow that you can find in this thread. There is also functionality in the api to move the robot from in the same way a the “Move Here” button does when given a waypoint. here it is in the api .

Hope this helps,
Sam

1 Like

Hi @sam.hilton ,

Thank you for the reply. Yes it’s seems to be exactly what I need. Unfortunately I’m not able to deploy the URCaps to have a look at it and see if that’s what I need. (See picture)

Running ursim 5.3 and sdk 1.6 and skd 1.9 have been installed. Any idea why the URcaps as a bundle exeption?

Event if i’m not able to open the ellipse example, i can see in the java code that getUserDefinedRobotPosition and RequestUserToMoveRobot Methods are used here.

I will test those methods and tell if it’s solved my problem.

Thanks,

Olivier

As you’ve found, you can still steal the sample code without having to compile and deploy the project, so that should give you enough to try and figure out what going on. Regarding the bundle exception, this is caused by the pom not having the right dependencies imported. I produced the same error when trying to add new jars to the pom. It shouldnt be thrown on a sample so im not sure what has happened, perhaps some folder in the project is corrupt I am not sure. It would be worth compiling some other samples to see if this also happens to them. If it does, I would just redownload the SDK version you want, delete the current samples you have, and reimport all the samples from the new SDK.