Universal Robots Forum

Robot pauses at the same line even after removing the pause feature

Folks,

I am perplexed by a weird behavior of our UR5e cobot. We are working on a robot program that has about 18 waypoints in total and 57 lines of code. Some waypoints needed to be retaught and verified by running the program in two stages.

I used a pause feature on line 22(at waypoint_7 in my program) to check that the robot works fine until that waypoint. Once I was comfortable with how the program worked I removed the pause feature on line 22.

After saving the program I ran the cycle to see if it all worked well, the robot ran through the whole program without pausing. But once I tried to replay the program it paused after line 22 or waypoint_7 again. There is no pause in the program and I have tried a lot of different things. Here is the strange stuff:

  • I restarted the robot and it still did the same thing, works through the whole program the first time and pauses at line_22 when I replay the program a second time.

  • When it pauses at line_22 there is no error or fault, the pause button doesn’t change to a resume button either. The cobot just sits there frozen

  • The robot runs through the whole program for the first time after making any changes, as simple as renaming a waypoint; but pauses at line_22 when replayed without making any changes

  • Resaving the file as a new program doesn’t solve the issue either, it still runs through the whole program the first time but pauses at guess what; line_22 again.

  • Also tried removing the waypoint at line_22 and reteaching a new waypoint which doesn’t seem to work either.

And the biggest issue is this is a dispensing application, I have my outputs turned off to the dispenser right now but will make a mess if this issue isn’t resolved.

Has anyone else seen a similar issue with the ‘line pause’ feature or know a fix for this issue?