Universal Robots Forum

Program not starting / 'Auto Start Program' stuck on disabled

Hello,

Running a UR-10e, 5.11.5.

I am having an issue with starting the robot program in a certain scenario, I believe this is a bug.

I have a push button which is mapped to ‘Auto Start & Init’. In remote control mode, this button will start the program, both at system startup and after the ‘stop’ pushbutton is pressed.

The issue comes up when I exit remote control mode and then stop the program with the stop icon on the touch screen.

When I go to restart the program, I get the dialog box stating ‘Auto program start will now be enabled. Do you also want to run the program?’.

Whether I press yes or no, ‘Auto Start Program’ on the Run screen stays disabled, and I cannot start the program at all. Worse, whether I change the mode to manual, or back to remote control, I still cannot start the program (with touch screen or with the start push button).

The only way I found to be able to run the program again is to either (1) restart the controller completely, or (2) under the installation tab, un-check the ‘load default program’ checkbox, at which point the play button on the touch screen works again.

(Summary for recreating the issue:

  1. Robot in remote control mode, start and stop push buttons can be used to start and stop the program.
  2. Exit remote control mode. (at this point Auto Program Start is still ‘Enabled’)
  3. Play the program, then stop it. (with touch screen controls) (now Auto Program Start is ‘Disabled’)
  4. Press the ‘play’ icon on screen - get dialog box stating ‘Auto Program start will be enabled, do you want to run the program’
  5. Regardless of choosing Yes/No on that dialog box, the program will not start and Auto Program Start remains ‘Disabled’
  6. Going back into remote control mode or going into manual mode does not help - the program will not run. )

Any insight?

Thanks,
Dorian

Hi,
I just tested this with 5.11.6 and I see a problem but there does seem to be some difference in how it works for me vs you. You are correct in that you should be able to switch into local mode and run the program from the teach pendant button in Polyscope. This does not work for me either. It seems like a bug and I will write it up as one. HOWEVER, I CAN switch back into remote mode and run the program via a separate DI wired and configured to StartProgram within the Installation.

5.11.6 is not released yet but should be any day.

Hi

We have came across the same problem, we had it in remote and then turned it off then then get auto start program dialogue

And the only way to stop is as Dorian Described above.

This cause’s a problem for our development as we need that to load the program as the default program, if not we will have to get a operator to load the program. which is not really ideal as we have it setup so there is no need to get into that level on the touch pendant on a operators level.

Thankyou