Universal Robots Forum

Daemon fail - Daemon resource doesn't load

Hello URCaps developers. I have tried to implement my own Swing Daemon Cap. Everything works well, (I have implemented only installation contribution and node ) I could build the URCap and I could insert the Cup to the URSim, but in my installation tab I can see that the Cap is not running and has fail status. I tried to figure out where the problem is and I found out that the daemon (which is in fact my Python script) was not added to the virtual folder of the /home/ur/ursim/ursim-5.5.1.82186/GUI/felix-cachefelix-cache/bundle???/ (Question marks define the number after connection of URCap usually the last number). I copied manually the script to the file (python script) to the folder of the bundle …/felix-cache/bundle???/data/com"Project Name"/src/main/resource/ “project path to resource”/impl/daemon/ and the URCap started to work.

The question is. Even if the resource (python script) is included in URCap package ( I can see it in the folder browser), why the python script is not included in the bundled folder. Do I have to modify pom.xml or something else.

The clue. I have installed the prepared example MyDaemonSwing that has the same structure and I can find the resource (python script) in the mentioned folder. So I really do not know how to setup the building process to declare that resource will unpack to the corresponding place.

Thank you very much for any advice.

I finally resolved the problem. It was my mistake. The Activator.java contains the daemon contribution and defines the source path to be loaded during bundling . It was in my case wrongly declared.

.

So, the advice. Pay attention where the path refers to in the Activator.java

1 Like