Universal Robots Forum

Can I compile my URCAPS as JavaSE-1.8?

Can I change the default URCAP JavaSE-1.6(java-8-openjdk-amd64) version to JavaSE-1.8(java-8-openjdk-amd64)?

image

I did the change, recompiled the urcap in my machine and it worked like a charm , on my ubuntu virtual Polyscope. My polyscope is the 5.9.

If I can do it, what the advantage of disadvantage in doing it?
And If I can do it ,why the sdk examples came with the older version?

Hi @tulio,

As stated here: Java versions used by PolyScope

You will get compatibility issues with the CB series. There is also more about the topic here: https://plus.universal-robots.com/urcap-basics/compatibility-chart-and-generations/

Ebbe

1 Like