Universal Robots Forum

SDK API Backwards Compatibility

Our URCaps was started a long time ago using the sdk version 1.2.56, and since then we never had to upgrade to a newer version since the features were enough for us.

Now we would like to introduce a new feature which requires us to upgrade to 1.6 or higher.
This raises 2 questions:

  • Is there a reason why we should only upgrade to 1.6 and not to the latest 1.11?
  • Would this change require our users to upgrade to a newer Polyscope version? If so, which?
  1. The only reason would be to be compatible with more versions.
  2. Yes, 1.6 requires 3.9.0/5.3.0 or later, and 1.11 requires 3.14.1/5.9.1 or later.

The URCap API/SDK version can be found in the release notes for each software release and they are not backwards compatible.