Universal Robots Forum

Bug fix: crash due to unsupported HTML-keyword

Hello. As it is now, URSim refuses to start up if an added URCap has the unsupported HTML-keyword “margin” - at least on my system. It gives the error in the terminal and loads to 100% and then gets stuck. I tried leaving it for an hour, so I know it’s not just slow. As it doesn’t start, there is no easy way to remove the URCap again.
I have forgotten the lack of support for this keyword twice now and had to remove and reinstall the entire program AND rename the folder it was in, to get it to start up without the broken URCap. There might be an easier way to remove the URCap, I just haven’t found, but I believe the point still stands.
Now, I know it is entirely my own fault for causing this problem, and I also realize this is only relevant to a few developers, but it would still be nice if, when it detected a fatal error like that, it removed the URCap and restarted.
I’m running 64-bit Ubuntu 16.04.3 and both URSim 3.5.1.10661 and 3.5.0.10584 exhibit this behaviour.

To remove the URCap, if PolyScope cannot boot, go to the hidden folder .urcaps in /home/ur/ursim-current/ and remove the associated .jar archive for your URCap.

1 Like

Had the same issue a few days ago…
For me it worked as follow:

  • Let PolyScope Boot up to that point were it seems to hang
  • Reprogram youre URCap without that margin css stuff
  • Try to reupload the URCap to youre ursim with maven (mvn install -P ursimvm)
  • Kill PolySope with “Ctrl+C”
  • Restart Polyscope

And then it boots up and work with the new edited URCap.
Maybe this works for you as well.