URsim can not see USB

Hello dear community,
I’m trying to open .urp file in URSim, I’m using vmware as virtual machine, but URSim can’t read USB, It even can’t see it. Only once it was opened and then it disappeared. I reinstalled everything now but it still doesn’t work. Any ideas?
Thanks in advance

You have not specified, why/if you need the USB at all? :slight_smile:

Do you know about the Programs folder on the desktop of the URSim? If you put your .urp in there, it will be accessible by the corresponding simulator.


I need to upload file from USB stick to URsim. So, if I want to upload file in those folders first of all I have to open USB stick.

Alright. So you’re not able to open the USB in Linux? You probably need to mount the USB in the virtual machine (disconnect it from Windows).

Another easy method is to copy the files from Windows and to the virtual machine; simply ctrl+c the files and ctrl+v inside the virtual machine. :slight_smile:

I’ve already tried them all but non of them are working. I think there is problem somewhere else.

Problem is that I can’t connect memory stick to virtual machine, only the host.

That is weird. I have never had the need to use USB directly in URSim, though, so I can’t say if it is working properly.

Did you try to simply copy - paste the files from Windows to URSim, as I mentioned in the last post?

Yes, But it says that directory can’t be found. I’ll try again different ways possibly it will work once.

I reinstalled everything and then tried copy/paste. It works! Thanks a lot.