Universal Robots Forum

URCap samples are not building

There is a URCaps Starter Package from UR+ that I downloaded and then followed a video tutorial where I made a simple URCap that controls turning on lights for a certain duration…

After the tutorial however, I tried to run the sample Swing typed URCaps (shown below):

I simply went onto the directory: /home/ur/sdk/sdk-1.4.4/samples/swing/one of the sample URCaps and I ran the command “mvn install -P ursim”, but the build ended up failing and I do not know why.

The command worked fine and built for the simple URCap that I followed from the tutorial, but it doesn’t work for the samples… I’ve tried testing this on some samples in the HTML sample and they ended up working, but it seems that the Swings samples do not…

Anyone know why?

Have you updated the URsim directory in your pom.xml file?

For example this is what I have in place for the SDK starter Package 1.5.0

	<!--Install path for the UR Sim-->
	<ursim.home>/home/ur/ursim/ursim-5.2.0.61336/</ursim.home>
2 Likes

You are correct.

I forgot to add path for the local UR sim.

Thanks!

Great! Happy to help.

1 Like