Universal Robots+

Testing pre-installed samples

Hi,

I’m trying to learn URcaps using SDK-1.2.41 under VirtualBox looking into the samples.

HelloWorld, pickorplace is running and I got ManipulateIO running with help from Roman.

It get build failures when I try to test other pre-installed examples
cyclecounter
idletime
coordinatemap
ellipse
localization
mydaemon
scriptfunction

Should it be possible to run these samples under SDK-1.2.41 ?

Uffe

I’m working on an URcap for a dualgripper with some extra features so the the 2x2 tool I/O is not enough. I’m planning to make a simple serial communication to make the extra commands.

So far I have worked on the ManipulateIO and expanded it the so it now has a 6 state radio group so I’m in the beginning in understanding how this works.

Is the only documentation for the object structure to look in the files via maven or is there a searchable help file somewhere I have missed?

I need to update polyscope variables to communicate the status therefore I’m very interested in the cyclecounter and idletime example.

I want to run the serial communication from a daemon so therefore I’m very interested in the mydaemon example.

Has anyone luck running these three examples ? Should I try an older SDK? maybe it has worked before.

Any good advice appreciated.

Uffe

I can run those examples, what errors are you getting?

image

image

image

What terminal command did you execute, when you received this error?

cp: cannot create regular file '/.urcaps/com.ur...`

That is your error right there. I suppose you are trying mvn install -P ursim ?
Then you need to go to pom.xml and input path to your ursim installation.

<!--Install path for the UR Sim-->
<ursim.home></ursim.home>  # this is normally in the file
<ursim.home>/home/ur/ursim-current</ursim.home> # this is what you have to put in (or different directory if you keep it somewher else)

Looks like @jbm is back from Easter holiday. :smiley:

Also for future reference: when you mark text in terminal, it is automatically copied. You can paste it with middle mouse button. It is separate clipboard than the one you use with ctrl+c.

1 Like

If you following my solution in your other post you can modify a few sections of the pom.xml file to fix this build error. I believe this is the same error I resolved in the other solution.

Hi dozminkowski,

Thank you for draw attention to missing install path.

It worked for the cyclyclecounter but unfortunately not for mydaemon.

Uffe

Hi Roman,

Can you list what sections to to modify? When I compare the files there are many differences.

Uffe

This time it failed while compiling Daemon. Looks like you’re trying to build C++ daemon. I’ve never done that. Maybe somebody else can help you. I only created Python daemons.

The MyDaemon example with the C++ daemon does not run in the Starter Package, as the cross compiler requires 64-bit intel, and the VM is 32-bit.