Universal Robots Forum

Unable to resolve osgi.wiring.package when deploying URcap

Hi all,

I have run into the following error when attempting to deploy an URcap on a CB-series cobot:

ERROR [Thread-3] 09:30:03 21/08/20: Error starting bundle.
org.osgi.framework.BundleException: Unable to resolve com.comp.lightUp [142](R 142.0): missing requirement [com.comp.lightUp [142](R 142.0)] osgi.wiring.package; (&(osgi.wiring.package=com.ur.urcap.api.contribution)(version>=1.8.0)(!(version>=2.0.0))) Unresolved requirements: [[com.comp.lightUp [142](R 142.0)] osgi.wiring.package; (&(osgi.wiring.package=com.ur.urcap.api.contribution)(version>=1.8.0)(!(version>=2.0.0)))]
	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4114)
	at org.apache.felix.framework.Felix.startBundle(Felix.java:2111)
	at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:977)
	at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:964)
	at com.ur.view.polyscope.module.ContributionBinding.startURCapBundles(ContributionBinding.java:57)
	at com.ur.view.polyscope.module.ContributionBinding.initialize(ContributionBinding.java:28)
	at com.ur.view.polyscope.module.ContributionBinding.registerContributions(ContributionBinding.java:107)
	at gui.main.URGUI.bindServices(URGUI.java:446)
	at gui.main.URGUI.bindServices(URGUI.java:404)
	at gui.main.URGUI.run(URGUI.java:205)

The maven installation runs cleanly, but the above error appears when starting the URsim. The URcap cannot be used.
I am using the Starter Package SDK 1.10.0 and deploying on a CB-series cobot with software version 3.9.1.

The error appears both for the URsim and the physical cobot. It appears for both the URcap I developed and the “lightUp” URcap from the tutorial. The error does not appear when deploying the URcap on e-series version 5.8.0 (URsim), e-series version 5.9 (physical cobot) and CB-series version 3.13.0 (URsim).

Does anyone know how to fix this?

Thanks in advance,
Karin

CB version 3.9.1 only supports URCap API versions up to 1.6.x. In this case you either need to use the Starter Package SDK 1.6.x and recompile your URCap, or update the robot to 3.13, or later, which supports 1.10.0.

e-series added the URCap API 1.10.0 in 5.8 which is why those work.

1 Like