Universal Robots Forum

The Tools sometimes not receiving their command

Hello,
I am new in the Robot business.
I have an UR16e, a OnRobot Compute Box, and there a Gripper RG6 and a Vacuum Gripper VGC10 are connected.
The Robot and the Compute Box are connected to the same Router. On the Router a fixed IP will be given for the robot and the compute box.

My problem is, that sometimes, and not reproduceable one of the tools do not perform their command.
I run the same program (all written in Polyscope) and then sometimes the gripper do not open ore close.
When I rerun without any changes in the code, it will work again.

First question, any idea what exactly i have to enter in the computebox settings?
And second, any idea what can cause such issues?

Thanks in advance

Hi Martin,

have you tried connecting it directly to the robot? Did this result in the same behavior? You could also try connecting one tool directly to the Tool IO.
Creating a minimum example, which makes this issues reproducible would also be helpful

If this does not help, the onRobot Support Team may also be able to guide you here.