Universal Robots+

MyDeamon example URCap not working with current StarterKit

Hi,

I am running the newest version of the Starterkit (SDK 1.10.0, URSim 5.8.0.10253) on a VirtualBox and I am having trouble getting the MyDeamon example cap to work.
I want to run the python deamon, the rest is commented out, I have also commented out the compile section in the pom.xml file. The deamon does not seem to start and Polyscope always just gives the “Could not set the title in the daemon process” error message.
As per suggestions in this forum I tried to create the folder “/programs” and run the ursim as sudo, but that does not change the situation.
Does anyone face the same issue/found a way to fix it?
Thank you!

I have no problem and the daemon is runnable.
Please check the below.

The permissions are set as in your screenshot and the Deamon starts without problems from the terminal.
Is there any chance to obtain a log of the Deamon process?

I don’t know how to log the daemon process.

The deamon may not be started once run as sudo.
It is not recommemded to start as sudo.

Please re-install ursim and try again.

$ ./install-ursim.sh UR3 (or UR5, UR10)

No success unfortunately. I get a strange error now though

12:53:53.563 ERROR - Problem with installation of bundle {thread: Thread-3 , loggerClass: 
com.ur.polyscope.urcaps.internal.daemonservice.DaemonServiceManager}
java.io.IOException: Could not set executable flag on file /home/ur/ursim/ursim-5.8.0.10253/GUI/felix- 
cache/bundle181/data/com/ur/urcap/examples/mydaemonswing/impl/daemon/-1253659008/run

Could it be connected to the way I build the cap? In my pom.xml I put

<ursim.home>~/ursim/ursim-5.8.0.10253</ursim.home>

and I build with

$ mvn install -P ursim 

Installing it manually after mvn install and putting it into the program folder failed as well though.

I have <ursim.home>/home/ur/ursim/ursim-5.8.0.10253</ursim.home> in pom.xml, can you try this?

I found the issue! It seems that the python setup got messed up somehow which lead to an import error. I have corrected the error and after reinstalling the ursim with

./install.sh

it works now.
I have also realized that logs of the deamon execution can be found under

/ursim/ursim-<version>/service/bundle@<yourcap>/log/log/current 

which was very useful.

Thank you everyone for your input!

Micheal could you elaborate on how you recognized a fault and what you did to fix it - I am having a similar issue.

Hi @warren.james,

the fist thing I would suggest is to have a look into your Deamon log which you can find in
/ursim/ursim-<version>/service/bundle@<yourcap>/log/log/current

From this you should already get a good idea what is going wrong.
Are you using a Python deamon? Do you require a certain Python version or third-party-libraries?

Reinstalling the ursim with ./install.sh certainly also does not hurt, just to be sure…

Thanks for the response micheal.

Unfortunately I don’t have a log appearing at that location.
My service folder is appearing in my home directory for ur but is empty.

I have notice that URSIM_ROOT doesn’t seem to be set - I think this may be why the service folder is in the wrong location

Edit : I do get a symbolic link that leads to a …/log/log/ location when ursim is running but the link disappears when ursim is not running. Also the ‘current’ folder doesn’t exist.