Universal Robots Forum

Starter Package SDK: virtual machine not starting

Hello everybody!

I downloaded the version 1.7.0 of the starter package (Starter+Package+SDK+1.7.0.zip) to my Windows 10 PC and unzipped it. Then I opened my Oracle VM Virtual Box Manager (version 6.0.8) and generated a new virtual machine. I used the settings “linux/ubuntu32Bit”, “~6GBMemory” and the file “URCaps Starter Package.vmdk” as a hard disc.
When I start this virtual machine, then I see the starting screen of virtual box (“BIOS screen”) but after that only a black window. Nothing else happens.
When I “switch off” the virtual machine and restart, then I can even see the grub menu in the boot process. Choosing “Ubuntu” (which is the default) results in a short flicker of the screen showing the “ubuntu color” (switching from text to vga mode?), but after that it is showing the black window again and nothing else happens.

I tried also the version 1.6.1, but I had the same results.

This picture shows my attempt to start the version 1.6.1. You see the properties of the virtual machine and the black window:

By the way: The URSim_VIRTUAL machine is working fine. But honestly I cannot remember, if I did something different defining this virtual machine.

What can I do?

-Ludwig

Have you tried using Ubuntu64 bit? That’s the only thing I can think of that might be different

That’s it!
I changed in VirtualBox the property “Ubuntu32Bit” to “Ubuntu64Bit” and it booted successfully to the graphical desktop.
Since I used Ubuntu32Bit for the URSim (I don’t know, if I did this by purpose or by chance), I did not even think about Ubuntu 64Bit.

I checked the docu again and I found only one hint to use the Ubuntu 64Bit: In the video on the page
https://plus.universal-robots.com/getting-started/myfirsturcap-using-the-starter-package/
there is an icon showing Ubuntu 64Bit as a part of the system. Maybe you (UR) can mention this fact in the text and also on the download page.

Thank you very much!