Universal Robots+

Remote TCP & Toolpath URCap Controller Start Failed

Hi everyone,

I am trying to test one of the g-code files using the Remote TCP & Toolpath URCap. I am doing it on URSim for testing purpose. Unfortunately, for some reason, when I start the controller under Installation>URCaps>Remote TCP & Toolpath it just says controller status: failed.

Can anyone help me with what could be the possible problem?

Best regards,
Zakriya

Hello Zakriya! How are you running the URSim on your computer? Are you using the virtual machine from the UR Support Site?

Hello Ypan,

Yes, I downloaded the UR Starter package which has URSim and Eclipse too.

The URCap SDK Starter Package is missing some dependencies required by the Remote TCP & Toolpath URCap. Would you mind running the following commands in a terminal to install the missing dependencies?

  • sudo apt-get install libcurl3-gnutls:i386
  • sudo apt-get install libbz2-1.0:i386

I installed the URCap SDK Starter Package on my laptop and ran it in VirtualBox. I was able to start the Controller after running the two commands above. Hope it works on your computer as well.

1 Like

I tried the two commands but it gives me the error about failure to fetch some files. Then asks me to try apt-get update and when I do that, it does not work either.

Can you share a screenshot of the error messages that you received when running these two commands?

Please make sure your virtual machine has access to the Internet.

I guess it was an internet issue because I just ran both the commands right now and they worked. Also, now the controller is running too after running the two commands like you said.

Thank you very much!

Thank you for confirming, Zakriya! Good to hear the issue has been resolved.

1 Like