Universal Robots Forum

Remote desktop to the controller UI

Sorry not a lot of time to type this out.

Give the robot internet access
Make sure sources.list has the sources for debian Jessie and not Wheezy like the CB series.

If you’re using that script that’s floating around, just replace the package install section with:

sudo apt-get update

sudo apt-get install x11vnc

It will install all the proper packages for Debian 8.9

Hi i did that and it installed sucessfully and i was able to connect to the controller. But Image and controls were very laggy and after two minutes connection crashed and wasnt possible to reconnect. Maybe some problem in configs ?

Hi,

I use this package all the time (e-series and CB3) :
Remote desktop to the controller UI

If you are having GUI lag via the VNC Viewer then it is probably something in your network connection to the robot that is causing this. I have never seen anyone have to adjust config settings in the VNC server setup to optimize the connection.

Hi,
I can confirm it works OK now. Changed switch and VNC works perfect. Thank you a lot for help.
Maybe have one aditional question. Did anybody try to stream PC to robot controller ? (to use it instead of HMI on small applications)

Hi,

I’m not sure I understand your question entirely but I can confirm that it is not possible to stream the PC’s HMI on the controller’s teach pendant.

It is possible to build a customized HMI using a PC or some dedicated industrial HMI. This would require programming skills, use of an ethernet connection with some fieldbus (example - modbus/tcp) or possibly a sockets connection to one of the robots servers.

Is it possible to have customized screens on e-series ? or you ment just stand-alone solution which would read information from robot via profinet or ethernet ?

It is not possible to customize the polyscope GUI.

Hi,
i’ve followed the procedure but it doesn’t work.
Evrithing is correctly installed, infact I’m able to run x11vnc by console. (But i would like to start the vnc server when I power the robot).
Could the problem be the clipping or scaling values?

PS: I’m using a UR10e.

You can start x11vnc at robot boot by editing crontab, adding:
@reboot x11vnc

I have solved some connections problems in the past by adding two options:
@reboot x11vnc -forever -shared

Thanks for the Magic files!
This worked perfectly.
It makes programming so much easier
I’ve installed it on both of the UR5e’s we have.

Great work!!!

@yuva1 Is there anyway you could put a updated version of this together?
The libs that are included are now out of date.

You can update your sources.list to point to the archive repository (deb Index of /debian jessie main) now that support for that version of debian has ended, then it will work again.

Please remember that any modifications to the controller OS by command line are at your own risk.