Profinet IO Device not found


I am trying to create a Profinet communication with a simatic s7-1200. But UR does not find the plc
and from the TIA portal it only says that UR cannot be reached. UR has a profile name and IP address.
I have tried to follow the universal robots profinet guide as best I can but it still does not work for me.

Am I missing something here?

Best regards Martin

Here’s a video I did of setting up a S71200 to a UR. It’s a bit tricky but once you figure it out works very well.

One thing to remember that I didn’t know, you need to be hooked directly to the PLC via hardwire to discover the robot. It does not always work via WiFi and definitely does not work over VPN. It has to do with how Profinet uses Mac addresses to identify the devices on the network.

1 Like

Besides what mbush mentioned, I would complete only that’s an existing guide already about how you can do that here: :

  • you can also check a program directly down below including also sharing/creating profinet I/O registers

  • don’t forget to activate the profinet in the robot to be reachable and discovered then restart the robot to be sure

  • don’t forget to be in the same subnet and pay attention to firewalls and your GW / SNET mask

  • install the gdsml and then everything should be fine

Hello @marius.dorobantu,
What do you mean by “pay attention to firewalls and your GW / SNET mask”? Which Firewalls? I have used this feature many times ago but i tried to use it today on an UR5e Series and i can’t get connet to the Robot on Tia Portal and i don’t know why!! I can see the name of the IO device on the robot and on Tia and i also can see that the robot have taken the IP adress sent by Tia Portal but the Profinet status is always yellow and not Green? even on Tia Portal i am not connected knowing that the API is an S7-1500 and i have used it before with the robot.Any ideas?
thank you,

What TIA version you are using ?
Normally if your PLC project does not have any issues or errors everything should be alright from your side. I will tell you why I said about firewalls :

  • Because for example McAffee in my case blocked the UR – the PLC is communicating with the robot through PROFINET over TCP – so I would suggest you to enable the profinet on the robot and then reboot it, also try this few times – then in TIA portal when you are online you should see no errors or communications interruption between PLC and Robot.
  • Everything has to be on green – this is an example with a scanner instead robot.


  • Also do not forget to add the fields like in the next window, otherwise could be a reason to not work

I know it’s an old post but I’ve found myself in this situation. In my case was the IP address and Profinet name. Here is a check list for others to tick:
After you setup the hardware in your TIA project as described in the video and guide:

  • Set the IP address in the same network as the PLC and as in your TIA project. You can change it in UR settings (hamburger menu) but you must reboot robot or toggle Disable/Enable ProfiNet IO Device from Installation to take effect;
  • In Tia Portal, device setting, set the Profinet Name either auto either manual to correspond to robot IO Device name.
  • If no name is present or want to change, in Tia Portal, go to Online Access and configure there the name.
  • Recompile and download the project to PLC.

Hope it works for others as well.