Universal Robots+

Profinet Error ROBOT-PLC

Dear forum members,

We try to build up a PROFINET communication between an UR10 (CB3, ROBOT VERSION 3.10) and a Beckhoff PLC (C6930). But a problem occurs in undefined cases.

Did anyone seen this message before? Can anyone please help us to solve this problem?

Thanks for your support!

We are using a Profinet Setting with a S7-1200 configured with TIA and also a Raspberry Pi configured with CodeSys.

This Error sometimes occurs after successful configuration while the plc is still connected to the TIA/CodeSys Client and i think it is a Bug. It disappears after disabling and reconnecting.

You should assure that the plc and robot are configured as master/slave and no other devices are connected as master.

1 Like

The reconnecting haven’t solved the problem at all. But i tried an other way. Since i changed the installation file, the problem haven’t occoured again. I hope that this state will remain for the further times :slight_smile:

Could it be that the change of the installation can solve it?

the installation only saves the actual state (enabled/disabled) and the configuration on loss of the input connection. But if it works after initialization and restart it should be fine :slight_smile: we don’t have issues during runtime of the PLC. This Strange Bug only occurs randomly when the TIA/CodeSys Client is connected. What was your workaround?

Hi,

Another RTDE client locking the data block ?

For instance Ethernet/IP (CIP protocol) cannot work with Profinet. The first RTDE client advising data for write operation lock the output.

Bye.

1 Like

Basically using Ethernet TCP/IP sockets should’nt interfere with Profinet. RTDE has it’s own reserved GPIO Registers. We’re not using any RTDE clients on Runtime or during configuration of Profinet so that could’nt be the cause of this issue but it’s good to mention that using RTDE and Profinet simultaneously can cause blocking issues which makes sense to me :wink:

The bad named Ethernet/IP protocol (CIP ODVA) do not refer to TCP/IP socket. Activation of this service is not compatible with Profinet since it uses also an RTDE channel to get data from the UR.