Plane Points creation


Why is it that Plane A can have its points displays and editable but Plane B can`t.

I need 6 of these editable planes for a program im writing.

Plane A was downloaded for this link: Complex pattern pallet example – 17769

Plane B was created by me from the install.

Polyscope 3.15


That node is folded (collapsed)

Click the circled area, it will expand the plane so you can see/edit the points.

This, stangely, doesnt work. It doesnt expand as you would think.

It doesnt work in the simulator, it doesnt work on my UR10 and it doesnt work on my UR5.

The strange thing is that the colllaps and expand does work on plane A.

Mayby its the polyscope version. I`ll try a different one tomorrow to see if it is a bug


I wonder if that’s intended to be like that or not.

I did some quick research and i have a theorie.
In older version of polyscope you needed to set the points one by one like a waypoint.
But in my version it has an automated process via a setup window.
This change might have removed the points from the installation but left the expand button.
or removed the points without anyone noticing & breaking the expand button.

Oke its a bug.

tried older version from polyscope and when i loaded 3.3 it worked. seems like they added a feature but broke another one in the progress. ill send a bug report.

If you want to get the points like this you need to install polyscope 3.3 in the simulator and eddit the install file.
!!BE AWARE!! some stuff doesnt comply with polyscope 3.3 so it will be deleted.

You’re right that it does seem like a bug. :slight_smile:
But it could also be intended and they just forgot to remove the “key” for minimizing and maximizing. You’re able to find the three waypoints again by going to “Teach this plane”. In there you can access your previously created waypoints, move to them and change them.

EDIT: You cannot however access the three waypoints from your sequence, so that’s a limitaton.