Universal Robots Forum

Graphics in Installation node

Hi! I’m trying to add some graphics at the installation node, I found the jfreechart library and try to embed in my project. I placed the jars of jfreechart and jcommons in the project directory and modify the pom file in the following way:

< Import-Package> com.ur.urcap.api*;version="[1.4.0,2.0.0)",
com.EconTech.Dashboard.jcommon-1.0.23.api.* , com.EconTech.Dashboard.jfreechart-1.0.19.api.*,
*
< /Import-Package>

< Embed-Dependency>jcommon, !org.osgi.core< /Embed-Dependency>
< Embed-Dependency>jfreechart, !org.osgi.core< /Embed-Dependency>

< dependency>
< groupId>org.jfree< /groupId>
< artifactId>jcommon< /artifactId>
< version>1.0.23< /version>
< /dependency>

< dependency>
< groupId>org.jfree< /groupId>
< artifactId>jfreechart< /artifactId>
< version>1.0.19< /version>
< /dependency>

Have someone worked with that library?? I’m new working with maven so maybe I committing a mistake probably or maybe it’s not possible to work with this library, I read your suggestions.

This article might help on how to import a third party jar into your project:
“Article under reconstruction”
Hope it helped, else let me know.

After looking at the article you might also want to take a look at this link:
https://mvnrepository.com/artifact/jfree/jfreechart/1.0.5

Thanks a lot for the reply, I did what the guide said about adding jars localized in Maven central repository and I checked the dependencies added to the pom file and they were fine. Now the warning icon in the side of the URCap in Setup Robot -> URCp is gone.

However the installation node looks as follows

I’ve been making some tests and the dependencies are causing this trouble, if you have any idea how can I solve this I’ll appreciate a lot. Mean while I’ll keep compiling the project to see if I find the problem.

Thanks for trying it out! Can you try to remove image in your pom.xml when you add the dependency ?

Thanks for the reply, I tried but the result was the same. The modifications in the Import Package and Embed Dependency are still necessary or should I erase it? The Guide on how to import a third-party jar-file don’t say anything about that.
For the record when I erase it the URCap turns the icon in warning again but I think is caused by the osgi bundle.

The first method you used with the import and embed is used when you don’t install it to your local maven repo, so you can stick with that. I think the real problem might be the fact that the jar that you are trying to import is depending on other jar as well. Sorry for the inconvenience.

Thanks a lot, I get it to work by including all the need dependencies, I tried just to call the dependencies as the guide said but it didn’t work, however I solved by embedding and importing the dependencies and the osgi core.
I share my pom file if some need to check this.

3 Likes

Hi

This topic is very useful and important for our operating robots.
I have tried and succeeded running Jfreechart on ursim.
it is realized with being embed jfreechart and jcommon repository but without being embed osgi core.