Universal Robots Forum

Freedrive crashing permanentely

Software version : 5.11.1.108318
Robot generation : UR10e

Steps to reproduce : Guiding the robot using freedrive.

Expected behavior : The robot can be guided without errors freely.

Actual behavior : The robot crashes after a couples of seconds with a violation, saying the the force limit has been exceeded.

Remeasuring the payload multiple times didn’t fix the error. Our current payload is 5.73kg.
I’ve added pictures of the error and our current safety settings. We do get the same error with least restricted settings however.


Hi @dominik.schwaiger,

Are you using a UR three switch teach pendant or an external three position enabling device? I see the 250mm/s speed limit icon between the speed slider and play buttons at the bottom of your screenshots so this issue could have something to do with that.

If possible you could try disabling the three position switch configuration temporarily and see if the issue remains?

Hi, we use our own 3PE. We did already try running it without it but that didn’t solve the issue either unfortunately.

So you’re only having issues in freedrive mode? Can you tell which joint it is that is causing the issue? Perhaps try moving them one by one in freedrive mode? I would also try creating a brand new installation file in case anything in your safety config is causing this.

I would expect this to be an issue with that individual joint/robot rather than a general software bug, therefore would recommend creating a service case in myUR for our customer service team to investigate.

I had this same(or very similar) problem but it was also alarming during programs. Turned out to be a failed F/T sensor. A replacement solved the problem.

Yes, the issue only persists in free drive mode. I tried isolating the error moving only one joint at a time, doing that I could not reproduce the error.
I also tried creating a new installation file, using that I couldn’t reproduce the error. Which safety settings might have an influence on that?

All of the robot limits will impact the allowed torque for each joint in some way, so it’s quite tough to narrow down from this info alone. You could try adding your previous limits back in one at a time to see if it can be recreated. If the issue still occurs when you reload your previous installation file, you can submit it to our customer service team through myUR for further investigation.