E-series Polyscope update failed

Hi all,

We just tried to update our Polyscope version from 5.3.1 to the newest version (5.11.8). We successfully incrementally updated from 5.3.1->5.4.3->5.5.1, and then when we attempted to update from there to 5.11.8 (build 10.10.444) we got the following error:

ERROR: [Errno 30] Read-only file system: ‘/media/urmountpoint_ljUPLv/install.rescue.sh’
Now installing update /media/urmountpoint_ljUPLv/update.full.5.11.8-build10.10.444.urup

There was a problem unpacking the update file: /media/urmountpoint_ljUPLv/update.full.5.11.8-build10.10.444.urup

We tried a fresh download of the file, and formatted the USB drive various ways. The incremental updates worked without any problems, so we’re wondering why the last one suddenly had issues. Any ideas on what could be the issue would be excellent.


I have exactly the same situation, I hope someone can answer
I wanted to install incrementally again from 5.5 to 5.6, 5.7, etc, buy I only found the 5.11 update

Hi, I had a similar problem.
In my case, I successfully updated the software by formatting the USB as FAT32.
The update failed when the USB format was exFAT and NTFS.

I forgot to update things here, but the solution was indeed to use FAT32. For some reason the incremental upgrades up to 5.5 worked with NTFS formatting, but you need a FAT32 drive to complete the final upgrade. If you want to use one that has worked for another upgrade, the specific one we used the SanDisk Cruzer glide 32GB USB stick (relatively cheap on Amazon in the US).