Connection failed on UR Log Viewer when attempting to record data with UR5

I am attempting to use the UR Log Viewer to record data live from the UR5, I have connected the robot to the PC with an ethernet cable and on the network status on the robot it shows connected. However when I use the same IP address in the Log Viewer it will state “Error! Connection Failed:” and doesn’t connect, I’ve added in rules in the firewall to allow the program, have checked if there is any security on the robot which would prevent the connection but there doesn’t seem to be anything. The IP address I am using is different than the WIFI IP address I use for the PC’s WIFI but am not sure if that is affecting it. Any suggestions would be greatly appreciated thank you!

Have you used the command line to PING the robot?

Can I ask where the command line is in UR Log Viewer? When I input the IP and press enter it will Ping the robot but I get no response from the ping,

Is your Ethernet port on your PC configured to the same network;

Is this a CB3 robot? If so, check the port speed settings on your PC. It is likely set to auto negotiate, but you may need to hard set it to 100 Mbps. CB3 robots will only support 100 Mbps speed over Ethernet, while E-series robots will support 1000 Mbps.

Yes it is configured to the same network, unless theres an issue in these IP settings?

I did change the port speed settings on the ethernet connection to 100Mbps half and full duplex however still no luck

I see you have as the robot IP address entered into the Log Viewer, and that same address for the port on your PC.

Assuming a subnet mask, the first 3 octets of the address must match, but the last octet needs to be unique. You can try the following:

PC port IP address:
Robot IP address:
Subnet mask for both devices:

1 Like

Yes that worked! Thank you very much for the help!