Universal Robots+

Codesys - ursim

Hi all,
I am trying to set up a connection between CODESYS and URSIM 5.6, using the network Ethernet/IP adapter.

I have a VM in Oracle running URSIM 5.6, I have started the Ethernet IP Adapter and get to the point in which I have the yellow light, meaning the adapter is running but not connected.
In the network settings of the Virtual Machine I configured the Host Only Adapter, from inside the VM if I run the command ifconfig my IP address is 192.168.56.101 .

Outside the VM, in my Windows OS, I installed CODESYS, created a Standard Project and using the .edf file provided by UR I installed the Universal Robots device, obtaining the following program structure CODESYS_UR_PROGRAM_TREE

From Windows the IP address of my HostOnly Network adapter is 192.168.56.102.
For this reason In the ethernet device I set that IP address as shown in the picture below:

As it concern the Universal_Robot device I set the IP address as 192.168.56.101 (the one seen inside my VM)

When I run my program The Ethernet device and the Ethernet IP Scanner seems to work fine but the Universal_robots device fails (as you can see in the first picture ), the log is the following:

Has everyone ever tried to use Codesys with URSIM and suceeded?
In a normal situation I would have tried to make it work with a real robot, not URSIM, to understand if the problem relies in the use of the VM or in my configuration in CODESYS but unfortunately I am not able to access the robots in the office any time soon.

Thanks for the help,
Best regards,
Castelli Pietro

I’m in the same situation also with the real robot. Using wireshark, it says malformed packet for the forward-open but I can’t understand why.

I hope someone could answer