Cant view Docker URSim UI

Hi all,

I’ve been trying to setup URSim in docker following the Polyscope 6 announcement recently, but I am struggling to connect to the VNC server and view the UI. Having followed the insctructions here, I have downloaded docker, and appear to have the URSim container running, though I am unable to connect to the VNC server of the container to view the UI, the connection through whichever viewer I use just times out and fails to connect. Hopefully I am missing something quick and easy, as everything appears to be in order. I have tried running both docker run --rm -it universalrobots/ursim_e-series and docker run --rm -it -p 5900:5900 -p 6080:6080 universalrobots/ursim_e-series and am unable to connect to the VNC server having run either command with either VNC viewer, or the browser VNC link. Screenshots of my running machine below:

I can access the polyscope and control logs of the container in separate terminals just fine, but for whatever reason, clicking the link through to the web client VNC viewer, or accessing the VNC server through VNC Viewer both result in a connection timeout.

Any help would be greatly appreciated, thanks.

I followed Pheobe’s guide here (GitHub - pheobeyeung/universal_robots_sdk: Implementation of Universal Robots's SDK with VSCode Dev Container and Docker) and after she helped me troubleshoot my dumb Windows for a bit, it eventually worked. It still does some weird stuff, like starting 2 instances of the server on top of each other or something, but it sorta works. Maybe give those instructions a shot?

I would ideally like to use the docker container pulled from the link UR privde rather than one developped by a 3rd party, I appreciate the suggestion but if anyone knows what is going wrong with UR provided docker container that would be great

I have a feeling I know what you’re seeing.

Open chrome and try this URL instead: http://localhost:6080/vnc_auto.html.

The console URL would also hang for me for reasons I didn’t care to troubleshoot.


Thanks, this worked!

Opening the vnc connection through the localhost link you sent worked, but only in Chrome, I usually use firefox as my default browser, but I was unable to view the UI through your link or the terminal link in firefox.

I also had to run the container with the port forwarding arguments, I couldn’t manage to connect without the port forwarding. With them though, I was able to view the container through both the link (in chrome) and using a VNC viewer connected to localhost:5900