Universal Robots Forum

Warning sign URCaps in setup of the robot

Hello,

I have written a URCaps program that I wanted to try out on the robot. The API version is the 1.11.0 and Polyscope from the robot 3.14. But in the settings under URCaps only a warning icon appears with my program. But in the simulator it runs without problems. Now to my question, is it possible to observe the startup process in the terminal as in the simulator, in order to find possible errors?

Thanks in advance
Dominik

Hi @d.amthor

Usually this is caused by using a version of the API that is too new for the polyscope version you are using, however in this case, you are using compatible version of the API and polyscope, though I have a couple of suggestions. Firstly make sure that you have run the install.sh file in the SDK folder to install the relevant API code into your VM. Secondly, if this URCap has had the API version updated from an older one, make sure that the API version has been changed in the .pom.xml file, and that the ppom.xml file does not contain any errors, as this can be another cause of this issue.

Hello,
Thanks for your tips @sam.hilton. I have tried out your hints. Unfortunately it still did not work. I ran the ./install.sh command and also checked the pom.xml and parent pom.xml. There were no errors to find.
Actual photo when I try to include the .urcap.

I have added some dependencies to Apache-Felix plugin which I use

Unfortunately, the warning occurs only when running on the robot and not in the VM.

Hi @d.amthor,

I’ve had some similar issue when deploying a URcap to my VM. In my case I had dependency issues and the faster way i found to solve that for me was to create a new project using ./newURCap.sh and copy/paste all my file in this new project.

Before doing that you can try to create and deploy an empty UrCap using that same ./newURCap.sh command to verify if it is indeed caused by a version mismatch.

One other thing you can try is to compile your project using <mvn clean install>. This will delete all previously compiled Java .class files and resources.

Thanks for your suggestion @sthjul. I was fortunately able to solve my problem in the meantime. It was due to a dependency that needed JDK1.8, which I didn’t know. I was able to detect it after I logged in to the robot as admin in the console. There I did the steps described in the URCap tutorial, chapter 14 Troubleshooting. I then logged into Apache Felix Bundle Manager with nc localhost 6666, then ps and found that my URCap was not marked as Active, only as Resolved.After trying to start it with start <bundle id>, I finally got an error message that helped me out, java.lang.UnsupportedClassVersionError: ... Unsupported major.minor version 52.0. I adjusted my imported library to JDK1.6 and my URCap is now running. Thanks again for the hints.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.