URSim Window Sizing Issues

I am trying to run UR sim on Windows 10 using Oracle VirtualBox 6.1, but can’t figure out how to resize the windows to fit my screen better. Everything is zoomed in way too far making it next to impossible to simulate a program. Any ways to fix this? I have tried adjusting settings in the Openbox Configuration Manager but nothing has seemed to work.

Check the bottom right of the screen for this icon. Should be what you’re looking for.

My screen has “Scale to 100% (unscaled output)” . This is what it looks like when that is selected.

The various resolutions are grayed out on yours. Mine let me choose which resolution. Not sure what you have going on there, then. Sorry. :frowning:

I am having the same issues. I think it has something to do with VirtualBox Guest additions not installing correctly.

EDIT:: Open a Xterm and run { xrandr -s 1920x1080 }

See if that works. It worked for me but after trying lots of things so Im not clear if that was the only fix required.

In my case, changing the graphics controller fixed the issue.

  1. Select the instance.
  2. Click on settings
  3. Click on Display /Graphic controller …
  4. Do trail and error with the options.

You should try with XRANDR in a Xterm as @mricchino said.

  1. Type xrandr and you will see all the available graphics modes. Actual mode is marked * . Choose the desired mode and count its row number.
  2. Type xrandr -s 5 , for example, if the row number of the desired graphic mode is 5. Try again with different modes until you get the best one.



Is there a way to automatically do this at startup? This works for me, but I have to type it in every time.

I tried doing it like it says here, but it does not work (even though it saves in my autostart file) Lubuntu Tutorials - Linux - A New Beginning - Migrating to Linux

I for one just never shutdown my VM. lol just save state & close