Universal Robots Forum

URsim Boot issues with sudo - cannot load and save files, no controller found

I installed URsim on Ubuntu 18.04.
I changed my Java version from 11 into 8 so that I can install the simulation.
After I installed it, I launched it using sudo ./start-ursim.sh
GUI was open but the terminal showed that ‘WARN - Not connected to controller, trying to send string: stop program’
Also, the message ’ could not save file ‘default, ensure the selected save directory exists’ appeared
But, I can run the simulation and it looks it can work.
However, when I tried to save the files(urp), it didn’t work at all.
When I tried to make a new folder, ‘Exception Caught in Thread AWT-EventQueue-0’ message popped up.

How can I solve this problem?

You should not start the URSim as sudo.
Run URSim as normal non-sudo user.

Thanks for your help. But, if I start without sudo, I got this message as below.

How can I solve that?
Should I change the other permission?

Did you check out the “How to setup Linux for URCaps Development”-article listed here?
How to install URSim for URCaps Development

Should I install URCaps SDK?
It looks like a huge file. So, I just tried to install ursim only (offiline simulator).
If I use a linux machine, should I install URCaps?
Also, my linux user is ‘hotae’. So, my directory is /home/hotae/ursim-
Do I have to create a new user named ‘ur’ ?

If SDK is installed or not, ursim can be running.
But user "ur " should be created if ursim or SDK is installed.

Ursim may be able to run with the other name, but I create user “ur” and set hostname “ursim.”


1 Like

Hi @hotae.lee,

I am assumeing you can fix it by running:
$chmod -R 777 ~/ursim-


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.