URP Not Loading, Fails Silently - No Loading Progress Bar Shows & Nothing Happens


I am running a UR10e with 5.11.8

I was updating a very large program on it, manually via polyscope, saving periodically, and not encountering any compile errors.

I shutdown the robot, then turned it back on and the program won’t load.
None of the backup files load either!

This represents a lot of work lost if I can’t open it.

Is there anywhere I can look (I thought there was a separate polyscope log, viewable if I ssh’d in)
The normal log doesn’t say anything about failing to load.

Please help!

in /root/ there is a polyscope.log

Could also try loading it in the simulator and see if that works?

The controller has also another logs apart from polyscope.log, located also in the root folder.
Here you have some code to figure out how to find them and transfer to your PC:

# login in 
ssh root@ROBOT_IP
# # # how to find where the flightreports are generated:
# go to the highest system folder
cd /
# find all the .zip files within the system
find . -type f -name '*.zip'
# go to the folder where they are located, in my case it was:
cd /data/root/flightreports/
# logout and copy all those files to your own log folder
scp root@ROBOT_IP:/data/root/flightreports/*.zip $DESTINATION_PATH_IN_YOUR_PC

You can open the zip log files with UR Log Viewer

PD: in the meantime, do you have any controller backups? That I get it’s bad your controller cannot load other backup files from the program, so have you tried to restore a full backup of the robot? The one you can do on the controller under Settings/System/Backup System.

Hi @tomg2

I solved my issue with the help from a fellow UR forum user:

Apparently, in one of my sub programs, large folders multiplied (by itself?) making all main programs using this sub program unloadable - in each main program, the box ‘update sub program’ was checked on. Luckily, I was able to open the sub program. After removing the unnecessary folders in the sub program and the main programs and unchecking the sub program update boxes, all programs loaded within seconds.

Maybe this will work for you too.

With kind regards,