Universal Robots Forum

URControl answer not readable

Hello, I wanted to create a small script using urscript language and test it.
Since polyscope only can handle urp+text files, I send commands to urcontrol directly as adviced here
(though I’ve seen a recommendation to use RTDE instead)
when I send commands to the URControl

  • nothing happens
  • it throws an unreadable output to me (See picture)

Info that might be usable: system virtual lubuntu from Starter Package 1.13, URSoftware 3.15.0.106151, ursim shows Disabled Network

Hi @pestsov,

  • It should work without the newline character, that’s only required for dashboard server not client interfaces.
  • The non human readable output is as expected, it’s a byte stream that would need to be unpacked.

As to whether doing it this way or using the RTDE is the best approach will depend on your use case/intended outcomes. If you can elaborate on these we can advise further.

Thanks.

Thanks, without the newline character it really worked!
plain
cat ./s.script | nc 10.0.2.15 30002
worked as well :slight_smile: